<!DOCTYPE html>
<html lang="en-CA" prefix="og: http://ogp.me/ns#">
	<head>
		<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="http://gmpg.org/xfn/11" />
		<link rel="pingback" href="https://streeter.ca/xmlrpc.php" />
		<title>North Toronto Daily Update - Streeter</title>

<!-- This site is optimized with the Yoast SEO plugin v11.0 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="A quick look at news, views and things to do in Forest Hill area"/>
<link rel="canonical" href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="North Toronto Daily Update - Streeter" />
<meta property="og:description" content="A quick look at news, views and things to do in Forest Hill area" />
<meta property="og:url" content="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/" />
<meta property="og:site_name" content="Streeter" />
<meta property="article:publisher" content="https://www.facebook.com/northtorontostreeter/" />
<meta property="article:tag" content="assault" />
<meta property="article:tag" content="Avenue Road" />
<meta property="article:tag" content="Bathurst Street" />
<meta property="article:tag" content="Beth Sholom Synagogue" />
<meta property="article:tag" content="Canadian Automobile Association" />
<meta property="article:tag" content="Columbus Centre" />
<meta property="article:tag" content="Dufferin Street" />
<meta property="article:tag" content="Eglinton Avenue West" />
<meta property="article:tag" content="Jewish Music Week" />
<meta property="article:tag" content="Jill Andrew" />
<meta property="article:tag" content="Lawrence Avenue West" />
<meta property="article:tag" content="Moore Park Ravine" />
<meta property="article:tag" content="robbery" />
<meta property="article:tag" content="Sonshine and Broccoli" />
<meta property="article:tag" content="St. Clair Avenue West" />
<meta property="article:tag" content="St. Monica&#039;s Catholic School" />
<meta property="article:tag" content="Toronto Police" />
<meta property="article:tag" content="Toronto-St. Paul&#039;s" />
<meta property="article:section" content="Daily Update" />
<meta property="article:published_time" content="2019-06-06T16:12:27+00:00" />
<meta property="article:modified_time" content="2019-06-07T13:27:11+00:00" />
<meta property="og:updated_time" content="2019-06-07T13:27:11+00:00" />
<meta property="og:image" content="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?fit=800%2C275&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?fit=800%2C275&#038;ssl=1" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="275" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="A quick look at news, views and things to do in Forest Hill area" />
<meta name="twitter:title" content="North Toronto Daily Update - Streeter" />
<meta name="twitter:site" content="@StreeterTO" />
<meta name="twitter:image" content="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?fit=800%2C275&#038;ssl=1" />
<meta name="twitter:creator" content="@StreeterTO" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://streeter.ca/#organization","name":"Town Crier","url":"https://streeter.ca/","sameAs":["https://www.facebook.com/northtorontostreeter/","https://twitter.com/StreeterTO"],"logo":{"@type":"ImageObject","@id":"https://streeter.ca/#logo","url":"https://streeter.ca/wp-content/uploads/2016/05/MyTC_logo_web_2016-e1463437412907.png","caption":"Town Crier"},"image":{"@id":"https://streeter.ca/#logo"}},{"@type":"WebSite","@id":"https://streeter.ca/#website","url":"https://streeter.ca/","name":"Streeter","publisher":{"@id":"https://streeter.ca/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://streeter.ca/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#webpage","url":"https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/","inLanguage":"en-CA","name":"North Toronto Daily Update - Streeter","isPartOf":{"@id":"https://streeter.ca/#website"},"image":{"@type":"ImageObject","@id":"https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#primaryimage","url":"https://streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg","caption":"TRY THIS: Sampling the wares at St. Monica's Spring Bazaar."},"primaryImageOfPage":{"@id":"https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#primaryimage"},"datePublished":"2019-06-06T16:12:27+00:00","dateModified":"2019-06-07T13:27:11+00:00","description":"A quick look at news, views and things to do in Forest Hill area"},{"@type":"Article","@id":"https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#article","isPartOf":{"@id":"https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#webpage"},"author":{"@id":"https://streeter.ca/author/streeter-staff/#author","name":"Streeter staff"},"publisher":{"@id":"https://streeter.ca/#organization"},"headline":"North Toronto Daily Update","datePublished":"2019-06-06T16:12:27+00:00","dateModified":"2019-06-07T13:27:11+00:00","commentCount":0,"mainEntityOfPage":"https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#webpage","image":{"@id":"https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#primaryimage"},"keywords":"assault,Avenue Road,Bathurst Street,Beth Sholom Synagogue,Canadian Automobile Association,Columbus Centre,Dufferin Street,Eglinton Avenue West,Jewish Music Week,Jill Andrew,Lawrence Avenue West,Moore Park Ravine,robbery,Sonshine and Broccoli,St. Clair Avenue West,St. Monica's Catholic School,Toronto Police,Toronto-St. Paul's","articleSection":"Daily Update"},{"@type":"Person","@id":"https://streeter.ca/author/streeter-staff/#author","name":"Streeter staff","image":{"@type":"ImageObject","@id":"https://streeter.ca/#personlogo","url":"https://secure.gravatar.com/avatar/b0b5e73bb4ecae682080b4be1da6d39a?s=96&d=mm&r=g","caption":"Streeter staff"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Streeter &raquo; Feed" href="https://streeter.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="Streeter &raquo; Comments Feed" href="https://streeter.ca/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Streeter &raquo; North Toronto Daily Update Comments Feed" href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/streeter.ca\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://streeter.ca/wp-includes/css/dist/block-library/style.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://streeter.ca/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://streeter.ca/wp-content/themes/colormag/style.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-child-style-css'  href='https://streeter.ca/wp-content/themes/colormag-child/style.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_google_fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_style-css'  href='https://streeter.ca/wp-content/themes/colormag-child/style.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-fontawesome-css'  href='https://streeter.ca/wp-content/themes/colormag/fontawesome/css/font-awesome.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-featured-image-popup-css-css'  href='https://streeter.ca/wp-content/themes/colormag/js/magnific-popup/magnific-popup.css?ver=20150310' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://streeter.ca/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://streeter.ca/wp-content/plugins/jetpack/css/jetpack.css?ver=7.4' type='text/css' media='all' />
<script type='text/javascript' src='https://streeter.ca/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://streeter.ca/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gadwpUAEventsData = {"options":{"event_tracking":"1","event_downloads":"zip|mp3*|mpe*g|pdf|docx*|pptx*|xlsx*|rar*","event_bouncerate":0,"aff_tracking":0,"event_affiliates":"\/out\/","hash_tracking":0,"root_domain":"streeter.ca","event_timeout":100,"event_precision":0,"event_formsubmit":0,"ga_pagescrolldepth_tracking":1,"ga_with_gtag":0}};
/* ]]> */
</script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/google-analytics-dashboard-for-wp/front/js/tracking-analytics-events.js?ver=5.3.8'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/google-analytics-dashboard-for-wp/front/js/tracking-scrolldepth.js?ver=5.3.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20190204'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/colormag-custom.js?ver=5.2.1'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/html5shiv.min.js?ver=5.2.1'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://streeter.ca/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://streeter.ca/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://streeter.ca/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.1" />
<link rel='shortlink' href='https://wp.me/p9Geyj-jvX' />
<link rel="alternate" type="application/json+oembed" href="https://streeter.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstreeter.ca%2Fnorth-toronto%2Fdaily-update%2Fnorth-toronto-daily-update%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://streeter.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstreeter.ca%2Fnorth-toronto%2Fdaily-update%2Fnorth-toronto-daily-update%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.1.3 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-8 {  margin: 0 auto; }
	.g-10 {  margin: 0 auto; }
	.g-11 {  margin: 0 auto; }
	.g-12 {  margin: 0 auto; }
	.g-13 {  margin: 0 auto; }
	.g-14 {  margin: 0 auto; }
	.g-15 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://i1.wp.com/streeter.ca/wp-content/uploads/2017/07/StreeterSiteIcon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/streeter.ca/wp-content/uploads/2017/07/StreeterSiteIcon.png?fit=144%2C144&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/streeter.ca/wp-content/uploads/2017/07/StreeterSiteIcon.png?fit=144%2C144&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/streeter.ca/wp-content/uploads/2017/07/StreeterSiteIcon.png?fit=144%2C144&#038;ssl=1" />

<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-104373724-1', 'auto');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
<!-- Streeter Internal Styles -->		<style type="text/css">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</style>
					<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://streeter.ca/?custom-css=b52f7c5603" />
				
		

		
		<link rel="stylesheet" href="//code.jquery.com/ui/1.12.1/themes/base/jquery-ui.css">
  <style>
  .ui-autocomplete {
    max-height: 100px;
    overflow-y: auto;
    /* prevent horizontal scrollbar */
    overflow-x: hidden;
	  z-index: 100000;
  }
  /* IE 6 doesn't support max-height
   * we use height instead, but this forces the menu to always be this tall
   */
  * html .ui-autocomplete {
    height: 100px;
  }
  </style>
		  <script src="https://code.jquery.com/jquery-1.12.4.js"></script>
  <script src="https://code.jquery.com/ui/1.12.1/jquery-ui.js"></script>
  <script>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</script>
				
		
		
	</head>
	
	
	
	
	
	

	<body class="post-template-default single single-post postid-75017 single-format-standard wp-custom-logo  wide better-responsive-menu">
				<div id="page" class="hfeed site">
			
			
			<header id="masthead" class="site-header clearfix ">
				<div id="header-text-nav-container" class="clearfix">

					
					
		<div class="inner-wrap">
			
								

			<div id="header-text-nav-wrap" class="clearfix">
				<div id="header-left-section">
											<div id="header-logo-image">
							
							<a href="https://streeter.ca/" class="custom-logo-link" rel="home"><img width="360" height="101" src="https://i0.wp.com/streeter.ca/wp-content/uploads/2018/09/StreeterLogoNewsViewsThings-web.png?fit=360%2C101&amp;ssl=1" class="custom-logo" alt="Streeter" srcset="https://i0.wp.com/streeter.ca/wp-content/uploads/2018/09/StreeterLogoNewsViewsThings-web.png?w=360&amp;ssl=1 360w, https://i0.wp.com/streeter.ca/wp-content/uploads/2018/09/StreeterLogoNewsViewsThings-web.png?resize=300%2C84&amp;ssl=1 300w" sizes="(max-width: 360px) 100vw, 360px" data-attachment-id="70867" data-permalink="https://streeter.ca/streeterlogonewsviewsthings-web-2/" data-orig-file="https://i0.wp.com/streeter.ca/wp-content/uploads/2018/09/StreeterLogoNewsViewsThings-web.png?fit=360%2C101&amp;ssl=1" data-orig-size="360,101" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="StreeterLogoNewsViewsThings-web" data-image-description="" data-medium-file="https://i0.wp.com/streeter.ca/wp-content/uploads/2018/09/StreeterLogoNewsViewsThings-web.png?fit=300%2C84&amp;ssl=1" data-large-file="https://i0.wp.com/streeter.ca/wp-content/uploads/2018/09/StreeterLogoNewsViewsThings-web.png?fit=360%2C101&amp;ssl=1" /></a>						</div><!-- #header-logo-image -->
											<div id="header-text" class="screen-reader-text">
													<h3 id="site-title">
								<a href="https://streeter.ca/" title="Streeter" rel="home">Streeter</a>
							</h3>
																			<p id="site-description">News, Views &amp; Things To Do in Our Neighbourhoods</p>
						<!-- #site-description -->
					</div><!-- #header-text -->
				</div><!-- #header-left-section -->
				<div id="header-right-section" style="/* border: solid 0px #ffffff; -webkit-box-shadow : 0px 0px 1px rgba(0,0,0,1.0); -moz-box-shadow : 0px 0px 1px rgba(0,0,0,1.0); box-shadow : 0px 0px 1px rgba(0,0,0,1.0); background-color : #fbbc67; */ padding : 10px 20px;">
					
					<div class="ui-widget" style="float:left; max-width:350px; max-height:90px; margin-right: 20px">
						
						<label for="project" class="screen-reader-text">Editions</label><input id="project" placeholder="Type in your edition" style="width: 290px; max-width: 98%; margin-bottom: 13px; border : solid 0px #ffffff; border-radius : 10px; moz-border-radius : 10px; -webkit-box-shadow : 0px 0px 1px rgba(0,0,0,1.0); -moz-box-shadow : 0px 0px 1px rgba(0,0,0,1.0); box-shadow : 0px 0px 1px rgba(0,0,0,1.0); font-size : 20px; color : #000000; padding : 10px 20px; background-color:#ffffcc;">
						<p id="project-description"><a href="/find-editions/"><i class="fa fa-newspaper-o fa-fw" aria-hidden="true" style="color:#000000;"></i> What's my edition?</a></p>
						
					</div>
					
					<div class="ui-widget" style="float:right; max-width:350px; max-height:90px;">
						
						<label for="neighbourhoods" class="screen-reader-text">Neighbourhoods</label><input id="neighbourhoods" placeholder="Type in your neighbourhood" style="width: 290px; max-width: 98%; margin-bottom: 13px; border : solid 0px #ffffff; border-radius : 10px; moz-border-radius : 10px; -webkit-box-shadow : 0px 0px 1px rgba(0,0,0,1.0); -moz-box-shadow : 0px 0px 1px rgba(0,0,0,1.0); box-shadow : 0px 0px 1px rgba(0,0,0,1.0); font-size : 20px; color : #000000; padding : 10px 20px; background-color:#ffffcc;">
						<p id="neighbourhoods-description"><a href="/find-neighbourhoods/"><i class="fa fa-map-marker fa-fw" aria-hidden="true" style="color:#000000;"></i> What's my neighbourhood?</a></p>
						
					</div>
					

				</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->

		</div><!-- .inner-wrap -->

					
										
		<nav id="site-navigation" class="main-navigation clearfix" role="navigation">
			<div class="inner-wrap clearfix">
				
				<h4 class="menu-toggle"></h4>
				<div class="menu-primary-container"><ul id="menu-main-nav-menu" class="menu"><li id="menu-item-72076" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-72076"><a href="https://streeter.ca">ALL EDITIONS</a>
<ul class="sub-menu">
	<li id="menu-item-28342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28342"><a href="https://streeter.ca/section/news/">News</a></li>
	<li id="menu-item-67854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67854"><a href="https://streeter.ca/section/views/">Views</a></li>
	<li id="menu-item-64745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64745"><a href="https://streeter.ca/section/arts-life/">Arts &#038; Life</a></li>
	<li id="menu-item-43051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43051"><a href="https://streeter.ca/section/sports/">Sports</a></li>
	<li id="menu-item-43041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43041"><a href="https://streeter.ca/section/business/">Business</a></li>
	<li id="menu-item-65406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65406"><a href="https://streeter.ca/section/then-now/">Then &#038; Now</a></li>
	<li id="menu-item-69308" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69308"><a href="https://streeter.ca/section/things-to-do/">THINGS TO DO</a></li>
	<li id="menu-item-69674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69674"><a href="https://streeter.ca/submit-event-streeter/">Submit an Event</a></li>
</ul>
</li>
<li id="menu-item-65028" class="menu-item menu-item-type-taxonomy menu-item-object-edition menu-item-65028"><a title="News &#038; view from the streets of the Central Toronto area" href="https://streeter.ca/edition/central-toronto/">Central Toronto</a></li>
<li id="menu-item-64748" class="menu-item menu-item-type-taxonomy menu-item-object-edition menu-item-64748"><a title="News &#038; view from the streets of the Forest Hill area" href="https://streeter.ca/edition/forest-hill/">Forest Hill</a></li>
<li id="menu-item-64746" class="menu-item menu-item-type-taxonomy menu-item-object-edition menu-item-64746"><a title="News &#038; view from the streets of the Leaside area" href="https://streeter.ca/edition/leaside/">Leaside</a></li>
<li id="menu-item-64747" class="menu-item menu-item-type-taxonomy menu-item-object-edition menu-item-64747"><a title="News &#038; view from the streets of the North Toronto area" href="https://streeter.ca/edition/north-toronto/">North Toronto</a></li>
<li id="menu-item-65029" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-65029"><a>Other Editions</a>
<ul class="sub-menu">
	<li id="menu-item-66124" class="menu-item menu-item-type-taxonomy menu-item-object-edition menu-item-66124"><a href="https://streeter.ca/edition/beaches-leslieville/">Beaches-Leslieville</a></li>
	<li id="menu-item-66123" class="menu-item menu-item-type-taxonomy menu-item-object-edition menu-item-66123"><a href="https://streeter.ca/edition/don-valley/">Don Valley</a></li>
	<li id="menu-item-65485" class="menu-item menu-item-type-taxonomy menu-item-object-edition menu-item-65485"><a href="https://streeter.ca/edition/riverdale-east-york/">Riverdale-East York</a></li>
	<li id="menu-item-65059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65059"><a href="https://streeter.ca/find-editions/">FIND YOUR EDITION</a></li>
</ul>
</li>
</ul></div>
				
									<i class="fa fa-search search-top"></i>
					<div class="search-form-top">
						<form action="https://streeter.ca/" class="search-form searchform clearfix" method="get">
   <div class="search-wrap">
      <input type="text" placeholder="Search" class="s field" name="s">
      <button class="search-icon" type="submit"></button>
   </div>
</form><!-- .searchform -->					</div>
							</div>
		</nav>

							

				</div><!-- #header-text-nav-container -->

				
			</header>
									<div id="main" class="clearfix">
				<div class="inner-wrap clearfix">
					
					
				
	
	<div id="primary">
		<div id="content" class="clearfix">

			
				
<article id="post-75017" class="post-75017 post type-post status-publish format-standard has-post-thumbnail hentry category-daily-update tag-assault tag-avenue-road tag-bathurst-street tag-beth-sholom-synagogue tag-canadian-automobile-association tag-columbus-centre tag-dufferin-street tag-eglinton-avenue-west tag-jewish-music-week tag-jill-andrew tag-lawrence-avenue-west tag-moore-park-ravine tag-robbery tag-sonshine-and-broccoli tag-st-clair-avenue-west tag-st-monicas-catholic-school tag-toronto-police tag-toronto-st-pauls location-casa-loma location-cedarvale location-chaplin-estates location-davisville location-deer-park location-forest-hill-north location-forest-hill location-glen-park location-humewood location-lawrence-park location-moore-park location-mount-pleasant location-oakwood-village location-south-hill location-summerhill location-wychwood-park location-yonge-eglinton edition-north-toronto">
	
   
         <div class="featured-image">
               <a href="https://streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg" class="image-popup"><img width="800" height="275" src="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?resize=800%2C275&amp;ssl=1" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="St. Monica&#039;s Spring Bazaar" srcset="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?resize=300%2C103&amp;ssl=1 300w" sizes="(max-width: 800px) 100vw, 800px" data-attachment-id="75020" data-permalink="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/attachment/stmonicas_9346/" data-orig-file="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?fit=800%2C275&amp;ssl=1" data-orig-size="800,275" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="stmonicas_9346" data-image-description="" data-medium-file="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?fit=300%2C103&amp;ssl=1" data-large-file="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/06/stmonicas_9346.jpg?fit=800%2C275&amp;ssl=1" /></a>
      
<div class="credit-cutline">
<span class="photo-credit"></span>
TRY THIS: Sampling the wares at St. Monica's Spring Bazaar. 
</div>

      </div>
   
   <div class="article-content clearfix">

   
   	<div class="above-entry-meta" style="float: right;"><span class="cat-links neighbourhood-links" style="text-transform: uppercase; border-radius: 3px; color: #ffffff; font-size: 12px; padding: 3px 10px; background-color: #B84200;">Edition:</span><span class="cat-links neighbourhood-links" style="text-transform: uppercase; font-weight:bold;">&nbsp;<a href="https://streeter.ca/edition/north-toronto/" rel="tag">North Toronto</a></span></div>   
   <div class="above-entry-meta"><span class="cat-links"><span class="daily-update-cat"><a href="https://streeter.ca/section/daily-update/"  rel="category tag">Daily Update</a>&nbsp;</span></span></div>
      <header class="entry-header">
   		<h1 class="entry-title">
   			North Toronto Daily Update   		</h1>
		<h2>A quick look at news, views and things to do in North Toronto neighbourhoods</h2>
   	</header>

   	<div class="below-entry-meta">
      <span class="posted-on"><a href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/" title="12:12 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2019-06-06T12:12:27-04:00">June 6, 2019</time><time class="updated" datetime="2019-06-07T09:27:11-04:00">June 7, 2019</time></a></span>
      <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a href="https://streeter.ca/author/streeter-staff/" title="Posts by Streeter staff" class="author url fn" rel="author">Streeter staff</a></span></span>

               <span class="comments"><a href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#respond"><i class="fa fa-comment"></i> 0 Comment</a></span>
      <span class="tag-links"><i class="fa fa-tags"></i><a href="https://streeter.ca/tag/assault/" rel="tag">assault</a>, <a href="https://streeter.ca/tag/avenue-road/" rel="tag">Avenue Road</a>, <a href="https://streeter.ca/tag/bathurst-street/" rel="tag">Bathurst Street</a>, <a href="https://streeter.ca/tag/beth-sholom-synagogue/" rel="tag">Beth Sholom Synagogue</a>, <a href="https://streeter.ca/tag/canadian-automobile-association/" rel="tag">Canadian Automobile Association</a>, <a href="https://streeter.ca/tag/columbus-centre/" rel="tag">Columbus Centre</a>, <a href="https://streeter.ca/tag/dufferin-street/" rel="tag">Dufferin Street</a>, <a href="https://streeter.ca/tag/eglinton-avenue-west/" rel="tag">Eglinton Avenue West</a>, <a href="https://streeter.ca/tag/jewish-music-week/" rel="tag">Jewish Music Week</a>, <a href="https://streeter.ca/tag/jill-andrew/" rel="tag">Jill Andrew</a>, <a href="https://streeter.ca/tag/lawrence-avenue-west/" rel="tag">Lawrence Avenue West</a>, <a href="https://streeter.ca/tag/moore-park-ravine/" rel="tag">Moore Park Ravine</a>, <a href="https://streeter.ca/tag/robbery/" rel="tag">robbery</a>, <a href="https://streeter.ca/tag/sonshine-and-broccoli/" rel="tag">Sonshine and Broccoli</a>, <a href="https://streeter.ca/tag/st-clair-avenue-west/" rel="tag">St. Clair Avenue West</a>, <a href="https://streeter.ca/tag/st-monicas-catholic-school/" rel="tag">St. Monica's Catholic School</a>, <a href="https://streeter.ca/tag/toronto-police/" rel="tag">Toronto Police</a>, <a href="https://streeter.ca/tag/toronto-st-pauls/" rel="tag">Toronto-St. Paul's</a></span></div>
   	<div class="entry-content clearfix">

		
   		<div class="dateline">June 6</div>
<h3>Photos of alleged naked man released</h3>
<p>Police have released photos of a man taken in 2018 during an alleged naked jogging incident and are hoping the public can identify him — since he has been identified as the naked man who approached women in midtown parks last month. He&#8217;s also been identified as the naked jogger observed in the Moore Park area in 2017. <a href="https://streeter.ca/north-toronto/news/midtowns-naked-jogger-may-be-back-police-say/">See the full story and photos.</a></p>
<div class="dateline">June 5</div>
<h3>Part of subway Line 1 shut down on Sunday</h3>
<p>If you&#8217;re heading downtown by transit on Sunday, you may want to consider an alternative route. Subway service between St. Clair and Union stations will be shut down on June 9 for installation of the new automatic train control signalling system, the TTC says. Shuttle buses will operate and Wheel-Trans service will be available for customers requiring accessible service within the closure area.</p>
<div class="dateline">June 4</div>
<h3>Woman assaulted, robbed in condo elevator</h3>
<p>Police have released a video of man being sought after a woman, 35, was robbed of her purse in a condominium building near St. Clair Avenue West and Avenue Road in early morning on June 2.  An unknown man allegedly the woman into an elevator and indicated he had a gun, before assaulting her and taking the purse. <a href="https://streeter.ca/forest-hill/news/man-sought-after-woman-assaulted-robbed-in-elevator/">See the full news story and picture.</a></p>
<div class="dateline">June 2</div>
<h3>Rain can&#8217;t keep St. Monica&#8217;s from raising funds</h3>
<p>Despite the inclement weather, St. Monica’s Catholic School successfully held its annual Spring Bazaar on May 25, complete with baked goods, crafts, a yard sale, a fire truck and bouncy castles.  For lots of pictures of people having fun, <a href="https://streeter.ca/north-toronto/arts-life/scenes-from-st-monicas-fundraising-bazaar/">see the story.</a></p>
<p>Parent volunteers cooked and baked food, the Toronto Fire Department had a fire truck on hand, Clap Art Studio provided crafts and bouncy castles added to the uplifting experience.</p>
<p>A silent auction, as well as a yard sale, packed with crafty goods and wares was available too.</p>
<div class="adbox">Story continues below ad<div class="g g-10"><div class="g-single a-77"><a class="gofollow" data-track="NzcsMTAsMSwxMA==" href="http://www.karbouzi.com"><img src="https://i0.wp.com/streeter.ca/wp-content/uploads/2018/01/Karbouzi-1802medrect.jpg?w=800&#038;ssl=1" data-recalc-dims="1"></a></div></div></div>
<div class="dateline">May 31</div>
<h3>Four Toronto streets voted among Ontario&#8217;s worst</h3>
<p>Eglinton Avenue East has been ranked the worst road in Ontario by voters in a CAA poll. The good news is that Eglinton Avenue <em>West</em> has dropped out of the top ten in the annual list. But also among this year&#8217;s top 10 are three other Toronto roads, including midtown&#8217;s Bathurst and Dufferin streets. <a href="https://streeter.ca/don-valley/featured/eglinton-east-ranked-worst-road-in-ontario-caa-poll/">See the story.</a></p>
<div class="print-float"><figure id="attachment_74816" aria-labelledby="figcaption_attachment_74816" class="article-main-image wp-caption alignnone" style="max-width: 800px; height: auto;"><img data-attachment-id="74816" data-permalink="https://streeter.ca/forest-hill/daily-update/forest-hill-daily-update/attachment/sonshine-broccoli/" data-orig-file="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/05/sonshine-broccoli.jpg?fit=800%2C275&amp;ssl=1" data-orig-size="800,275" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="sonshine-broccoli" data-image-description="" data-medium-file="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/05/sonshine-broccoli.jpg?fit=300%2C103&amp;ssl=1" data-large-file="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/05/sonshine-broccoli.jpg?fit=800%2C275&amp;ssl=1" class="size-full wp-image-74816" src="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/05/sonshine-broccoli.jpg?resize=800%2C275&#038;ssl=1" alt="" width="800" height="275" srcset="https://i1.wp.com/streeter.ca/wp-content/uploads/2019/05/sonshine-broccoli.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/streeter.ca/wp-content/uploads/2019/05/sonshine-broccoli.jpg?resize=300%2C103&amp;ssl=1 300w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims="1" /><figcaption id="figcaption_attachment_74816" class="wp-caption-text credit-cutline"><span class="photo-credit"></span>FOR THE COOL KIDS: Sonshine and Broccoli perform during Jewish Music Week.</figcaption></figure></div>
<div class="dateline">May 29</div>
<h3>Local events for Jewish Music Week</h3>
<p>Jewish Music Week is underway in Toronto with concerts, lectures, films and other musical events, many of them presented in the Forest Hill and North Toronto areas. The schedule began on May 26 but several local events are still to come.</p>
<p>On May 30 Eric Gertner presents “The Holocaust’s Impact on Music” at the Columbus Centre on Lawrence Avenue West, <span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;">examining the impact of the Nazis’ coming to power and the Holocaust on Jewish musicians and Jewish music from 1933 to the present (check our <a href="https://streeter.ca/north-toronto/things-to-do/may-30-the-holocausts-impact-on-music/">Things to Do listing</a> for more information.) </span>Children’s entertainers Sonshine and Broccoli perform the &#8220;Cool Kids Concert&#8221; on June 2 at ​Beth Sholom Synagogue on Eglinton Avenue West (see <a href="https://streeter.ca/forest-hill/things-to-do/june-2-concert-for-the-cool-kids-at-beth-sholom/">Things To Do listing</a>.) You can see the full schedule of events on the <a href="http://www.jewishmusicweek.com">Jewish Music Week website</a>, including both ticketed and free events.</p>
<div class="dateline">May 28</div>
<h3>Reverse library cuts, MPP urges</h3>
<p>Toronto-St. Paul&#8217;s MPP Jill Andrew was joined by library workers and users for a press conference at Queen&#8217;s Park today against planned library cuts. Andrew tabled a motion on May 16 calling on Premier Doug Ford to reverse his library cuts, which she says are already hurting communities. “Not only are libraries community hubs, but they are democratic spaces,” Andrew said in a press release. “Families, children, seniors, and vulnerable people can all find programs and support at the library that improve their quality of life.&#8221; You can see Andrew, who is the NDP cultural critic, <a href="https://www.dropbox.com/s/w97zpl262cm1423/Q7_Andrew_04-18-2019.mp4?dl=0">questioning the government about the cuts in the legislature on video.</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-75017" class="share-twitter sd-button share-icon no-text" href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-75017" class="share-facebook sd-button share-icon no-text" href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div>
		
		<!-- ARTICLE META -->
		<hr />
		<p class="subhead" style="font-weight: bold;">About this article:</p>
		<p class="meta">
			<i class="fa fa-user fa-fw" aria-hidden="true"></i> By: <a href="https://streeter.ca/author/streeter-staff/" title="Posts by Streeter staff" class="author url fn" rel="author">Streeter staff</a><br />
			<i class="fa fa-calendar fa-fw" aria-hidden="true"></i> Posted: Jun 6 2019 12:12 pm<br />
			<i class="fa fa-folder-o fa-fw" aria-hidden="true"></i> Filed in: <span class="daily-update-cat"><a href="https://streeter.ca/section/daily-update/"  rel="category tag">Daily Update</a></span><br />
							<i class="fa fa-newspaper-o fa-fw" aria-hidden="true"></i> Edition: <a href="https://streeter.ca/edition/north-toronto/" rel="tag">North Toronto</a><br />
										<i class="fa fa-map-marker fa-fw" aria-hidden="true"></i> Neighbourhood: <a href="https://streeter.ca/neighbourhood/casa-loma/" rel="tag">Casa Loma</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/cedarvale/" rel="tag">Cedarvale</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/chaplin-estates/" rel="tag">Chaplin Estates</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/davisville/" rel="tag">Davisville</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/deer-park/" rel="tag">Deer Park</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/forest-hill-north/" rel="tag">Forest Hill North</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/forest-hill/" rel="tag">Forest Hill Village</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/glen-park/" rel="tag">Glen Park</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/humewood/" rel="tag">Humewood</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/lawrence-park/" rel="tag">Lawrence Park</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/moore-park/" rel="tag">Moore Park</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/mount-pleasant/" rel="tag">Mount Pleasant</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/oakwood-village/" rel="tag">Oakwood Village</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/south-hill/" rel="tag">South Hill</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/summerhill/" rel="tag">Summerhill</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/wychwood-park/" rel="tag">Wychwood Park</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/neighbourhood/yonge-eglinton/" rel="tag">Yonge-Eglinton</a><br />
									<i class="fa fa-tag fa-fw" aria-hidden="true"></i> Tagged: <a href="https://streeter.ca/tag/assault/" rel="tag">assault</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/avenue-road/" rel="tag">Avenue Road</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/bathurst-street/" rel="tag">Bathurst Street</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/beth-sholom-synagogue/" rel="tag">Beth Sholom Synagogue</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/canadian-automobile-association/" rel="tag">Canadian Automobile Association</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/columbus-centre/" rel="tag">Columbus Centre</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/dufferin-street/" rel="tag">Dufferin Street</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/eglinton-avenue-west/" rel="tag">Eglinton Avenue West</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/jewish-music-week/" rel="tag">Jewish Music Week</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/jill-andrew/" rel="tag">Jill Andrew</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/lawrence-avenue-west/" rel="tag">Lawrence Avenue West</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/moore-park-ravine/" rel="tag">Moore Park Ravine</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/robbery/" rel="tag">robbery</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/sonshine-and-broccoli/" rel="tag">Sonshine and Broccoli</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/st-clair-avenue-west/" rel="tag">St. Clair Avenue West</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/st-monicas-catholic-school/" rel="tag">St. Monica's Catholic School</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/toronto-police/" rel="tag">Toronto Police</a> <span style="color: #e19d66;" aria-hidden="true">&#8226;</span> <a href="https://streeter.ca/tag/toronto-st-pauls/" rel="tag">Toronto-St. Paul's</a>					</p>
		<!-- /ARTICLE META -->

   	</div>

   </div>

	</article>
			
		</div><!-- #content -->

      
		<ul class="default-wp-page clearfix">
			<li class="previous"><a href="https://streeter.ca/toronto/arts-life/blast-radius-columnists/plenty-of-options-in-midtown-for-young-ballet-fans/" rel="prev"><span class="meta-nav">&larr;</span> Plenty of options in midtown for young ballet fans</a></li>
			<li class="next"><a href="https://streeter.ca/north-toronto/news/midtowns-naked-jogger-may-be-back-police-say/" rel="next">Midtown&#8217;s naked jogger may be back, police say <span class="meta-nav">&rarr;</span></a></li>
		</ul>
	
      
      

<h4 class="related-posts-main-title"><i class="fa fa-thumbs-up"></i><span>You May Also Like</span></h4>

<div class="related-posts clearfix">

      <div class="single-related-posts">

      
      <div class="article-content">

         <h3 class="entry-title">
            <a href="https://streeter.ca/toronto/news/new-digs-in-old-school/" rel="bookmark" title="New digs in old school">New digs in old school</a>
         </h3><!--/.post-title-->

         <div class="below-entry-meta">
            <span class="posted-on"><a href="https://streeter.ca/toronto/news/new-digs-in-old-school/" title="6:35 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2011-11-28T18:35:51-04:00">November 28, 2011</time></a></span>            <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://streeter.ca/author/tc-staff/" title="Town Crier staff">Town Crier staff</a></span></span>
            <span class="comments"><i class="fa fa-comment"></i><span>Comments Off<span class="screen-reader-text"> on New digs in old school</span></span></span>
         </div>

      </div>

   </div><!--/.related-->
      <div class="single-related-posts">

      
      <div class="article-content">

         <h3 class="entry-title">
            <a href="https://streeter.ca/toronto/arts-life/health-wellness/mobile-crisis-team-coming-to-54-and-55-divisions/" rel="bookmark" title="Mobile crisis team coming to 54 and 55 divisions">Mobile crisis team coming to 54 and 55 divisions</a>
         </h3><!--/.post-title-->

         <div class="below-entry-meta">
            <span class="posted-on"><a href="https://streeter.ca/toronto/arts-life/health-wellness/mobile-crisis-team-coming-to-54-and-55-divisions/" title="4:10 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2013-03-27T16:10:19-04:00">March 27, 2013</time></a></span>            <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://streeter.ca/author/shawns/" title="Shawn Star">Shawn Star</a></span></span>
            <span class="comments"><i class="fa fa-comment"></i><span>Comments Off<span class="screen-reader-text"> on Mobile crisis team coming to 54 and 55 divisions</span></span></span>
         </div>

      </div>

   </div><!--/.related-->
      <div class="single-related-posts">

      
      <div class="article-content">

         <h3 class="entry-title">
            <a href="https://streeter.ca/north-toronto/news/two-nabbed-in-yonge-eg-armed-robbery/" rel="bookmark" title="Two nabbed in Yonge-Eg armed robbery">Two nabbed in Yonge-Eg armed robbery</a>
         </h3><!--/.post-title-->

         <div class="below-entry-meta">
            <span class="posted-on"><a href="https://streeter.ca/north-toronto/news/two-nabbed-in-yonge-eg-armed-robbery/" title="3:42 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2015-11-17T15:42:28-04:00">November 17, 2015</time></a></span>            <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="https://streeter.ca/author/shawns/" title="Shawn Star">Shawn Star</a></span></span>
            <span class="comments"><i class="fa fa-comment"></i><span>Comments Off<span class="screen-reader-text"> on Two nabbed in Yonge-Eg armed robbery</span></span></span>
         </div>

      </div>

   </div><!--/.related-->
   
</div><!--/.post-related-->


      
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/north-toronto/daily-update/north-toronto-daily-update/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://streeter.ca/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='75017' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->
	</div><!-- #primary -->

	
<div id="secondary">
			
		<aside id="adrotate_widgets-53" class="widget adrotate_widgets clearfix"><div class="g g-12"><div class="g-single a-118"><a class="gofollow" data-track="MTE4LDEyLDEsMTA=" href="https://www.openeyestudio.ca/Headshots/"><img src="https://streeter.ca/wp-content/uploads/2019/03/OpenEye-1903medrect-2b.jpg"></a></div></div></aside>
	</div>
	

</div><!-- .inner-wrap -->
</div><!-- #main -->




<footer id="colophon" class="clearfix ">
	
<div class="footer-widgets-wrapper">
	<div class="inner-wrap">
		<div class="footer-widgets-area clearfix">
         <div class="tg-footer-main-widget">
   			<div class="tg-first-footer-widget">
   				<aside id="adrotate_widgets-16" class="widget adrotate_widgets clearfix"><div class="g g-5"><div class="g-single a-67"><a class="gofollow" data-track="NjcsNSwxLDEw" href="http://editoreric.com"><img src="https://streeter.ca/wp-content/uploads/2017/08/EditorEric-1708medrect.jpg"></a></div></div></aside>   			</div>
         </div>
         <div class="tg-footer-other-widgets">
   			<div class="tg-second-footer-widget">
   				<aside id="nav_menu-5" class="widget widget_nav_menu clearfix"><h3 class="widget-title"><span>WHAT IS STREETER?</span></h3><div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-43251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43251"><a href="https://streeter.ca/about/">About Us</a></li>
<li id="menu-item-65039" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65039"><a href="https://streeter.ca/publish-on-streeter-ca/">Publish on Streeter.ca</a></li>
<li id="menu-item-43252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43252"><a href="https://streeter.ca/contact/">Contact Us</a></li>
<li id="menu-item-43281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43281"><a href="/">Home</a></li>
</ul></div></aside>   			</div>
            <div class="tg-third-footer-widget">
               		<aside id="recent-posts-5" class="widget widget_recent_entries clearfix">		<h3 class="widget-title"><span>LATEST STORIES</span></h3>		<ul>
											<li>
					<a href="https://streeter.ca/beaches-leslieville/daily-update/beaches-leslieville-daily-update/">Beaches-Leslieville Daily Update</a>
									</li>
											<li>
					<a href="https://streeter.ca/don-valley/daily-update/don-valley-daily-update/">Don Valley Daily Update</a>
									</li>
											<li>
					<a href="https://streeter.ca/riverdale-east-york/daily-update/riverdale-east-york-daily-update/">Riverdale-East York Daily Update</a>
									</li>
											<li>
					<a href="https://streeter.ca/north-toronto/news/midtowns-naked-jogger-may-be-back-police-say/">Midtown&#8217;s naked jogger may be back, police say</a>
									</li>
											<li>
					<a href="https://streeter.ca/north-toronto/daily-update/north-toronto-daily-update/">North Toronto Daily Update</a>
									</li>
											<li>
					<a href="https://streeter.ca/toronto/arts-life/blast-radius-columnists/plenty-of-options-in-midtown-for-young-ballet-fans/">Plenty of options in midtown for young ballet fans</a>
									</li>
					</ul>
		</aside>            </div>
            <div class="tg-fourth-footer-widget">
               <aside id="nav_menu-4" class="widget widget_nav_menu clearfix"><h3 class="widget-title"><span>SECTIONS</span></h3><div class="menu-footer-nav-menu-container"><ul id="menu-footer-nav-menu" class="menu"><li id="menu-item-65214" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65214"><a href="https://streeter.ca/section/news/">NEWS</a></li>
<li id="menu-item-65218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65218"><a href="https://streeter.ca/section/views/">VIEWS</a></li>
<li id="menu-item-65217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65217"><a href="https://streeter.ca/section/arts-life/">ARTS &amp; LIFE</a></li>
<li id="menu-item-65215" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65215"><a href="https://streeter.ca/section/sports/">SPORTS</a></li>
<li id="menu-item-65216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65216"><a href="https://streeter.ca/section/business/">BUSINESS</a></li>
</ul></div></aside>            </div>
         </div>
		</div>
	</div>
</div>	<div class="footer-socket-wrapper clearfix">
		<div class="inner-wrap">
			<div class="footer-socket-area">
				<div class="footer-socket-right-section">
									</div>

				<div class="footer-socket-left-section">
					<div class="copyright">Copyright &copy; 2019 <a href="https://streeter.ca/" title="Streeter" ><span>Streeter</span></a>. All rights reserved.</div><div class="copyright"> &nbsp; &middot; &nbsp; <a rel="nofollow" href="https://streeter.ca/wp-login.php">Log in</a></div>				</div>
			</div>
		</div>
	</div>
</footer>

<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>

</div><!-- #page -->
	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/streeter.ca\/north-toronto\/daily-update\/north-toronto-daily-update\/":75017};
	</script>
				<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20190201'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/streeter.ca\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/streeter.ca\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.3'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201923'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Junaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://streeter.ca/wp-includes/js/comment-reply.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/jquery.bxslider.min.js?ver=4.2.10'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/colormag-slider-setting.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/navigation.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/sticky/jquery.sticky.js?ver=20150309'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/sticky/sticky-setting.js?ver=20150309'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/magnific-popup/jquery.magnific-popup.min.js?ver=20150310'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/magnific-popup/image-popup-setting.js?ver=20150310'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/fitvids/jquery.fitvids.js?ver=20150311'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/themes/colormag/js/fitvids/fitvids-setting.js?ver=20150311'></script>
<script type='text/javascript' src='https://streeter.ca/wp-includes/js/wp-embed.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/streeter.ca\/wp-admin\/admin-ajax.php","nonce":"dbf8987904","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/streeter.ca\/wp-login.php?redirect_to=https%3A%2F%2Fstreeter.ca%2Fnorth-toronto%2Fdaily-update%2Fnorth-toronto-daily-update%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://streeter.ca/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.4'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201923.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.4',blog:'143052743',post:'75017',tz:'-4',srv:'streeter.ca'} ]);
	_stq.push([ 'clickTrackerInit', '143052743', '75017' ]);
</script>
</body>
</html>
